האתר של הופ

יש לך שאלה על של חבילת Mozilla/Seamonkey? אולי יש לך תשובה לשאלות של אחרים?

האתר של הופ

הודעה שלא נקראהעל ידי טרודי » 14 אוקטובר 2003, 13:20

שלום,
הילדים שלי רוצים לשחק באתר של הופ http://www.hop.co.il
אבל מוזילה לא מצליח להתמודד איתו.
ב-IE, האתר מציג חלון פתיחה ומיד פותח חלון אחר שתופס את כל המסך.
במוזילה, צריך להקליק בחלון הפתיחה כדי לקבל את החלון השני.
ב-IE, אחרי שהחלון השני טוען את האתר, הוא אומר "ברוכים הבאים לשכונה של הופ", העפיפון נעלם, ומופיעה השכונה עם הדמויות של הופ.
במוזילה, הוא אומר אותו דבר, העפיפון נעלם, מופיעה התמונה הראשונה של אנימצית השכונה, ואז המוזילה נתקע.
לא מגיב לשום מקש או לחיצת עכבר, כולל close מה-window manager
הפתרון היחיד הוא לעשות לו kill מחלון terminal

מדובר על מוזילה 1.4 על RH9 וgnome 2.2.0-, עם shockwave flash 6.0 r79

עצות? רעיונות?[/url]
טרודי
 

מוזר - דווקא אצלי הוא עובד תקין

הודעה שלא נקראהעל ידי אורח » 14 אוקטובר 2003, 13:47

מנדרייק 9.1 מוזילה 1.4 KDE3.1
נפתח חלון חדש ניתן לגלוש בו כרגיל (בלי סרגלי הכלים)
שגיב
אורח
 

Re: האתר של הופ

הודעה שלא נקראהעל ידי צחי » 14 אוקטובר 2003, 15:37

טרודי כתב:שלום,
ב-IE, האתר מציג חלון פתיחה ומיד פותח חלון אחר שתופס את כל המסך.
במוזילה, צריך להקליק בחלון הפתיחה כדי לקבל את החלון השני.
קודם כל, הם פותחים את IE בחלון מסך מלא (כמו ללחוץ על F11). אני לא בטוח שזה אפשרי בכלל במוזילה, שהאתר יבחר את צורת החלון. במקום זה, בדפדפני מוזילה הם פותחים חלון חדש בלי סרגלים. אם הם היו פותחים את החלון הזה בצורה אוטומטית כמו ב-IE, רוב הסיכויים שהוא היה נחסם ולא נפתח, בגלל חסימת החלונות הקופצים של מוזילה, שמיועדת לחסימת פרסומות מעצבנות. לכן אתה צריך ללחוץ כדי לפתוח את החלון באופן יזום.
טרודי כתב:ב-IE, אחרי שהחלון השני טוען את האתר, הוא אומר "ברוכים הבאים לשכונה של הופ", העפיפון נעלם, ומופיעה השכונה עם הדמויות של הופ.
במוזילה, הוא אומר אותו דבר, העפיפון נעלם, מופיעה התמונה הראשונה של אנימצית השכונה, ואז המוזילה נתקע.
לא מגיב לשום מקש או לחיצת עכבר, כולל close מה-window manager
הפתרון היחיד הוא לעשות לו kill מחלון terminal

מדובר על מוזילה 1.4 על RH9 וgnome 2.2.0-, עם shockwave flash 6.0 r79

עצות? רעיונות?

לי יש WinXP, ולא נתקלתי בבעיות. נסה לעדכן לגרסה 1.4.1 שיצאה שילשום, אולי זה יפתור את הבעיה.
צחי

‎
 
הודעות: 1779
הצטרף: 31 דצמבר 2002, 00:27

הבעיה נעלמה

הודעה שלא נקראהעל ידי טרודי » 14 אוקטובר 2003, 21:33

הנה מה שעשיתי:
חשבתי להתקין מחדש את הפלאש.
הורדתי את החבילה, הרצתי את ה-installer שבא בפנים, ושמתי לב שהוא אומר שהוא צריך את חבילת ttfonts.
עצרתי את ההתקנה.
חיפשתי וראיתי שיש לי חבילות ttfonts בקוריאנית ויפנית (הגיעו עם ה-RH9), אבל לא משהו כללי בשם זה.
אמרתי לעצמי שזה זמן טוב להתקין את ה-TrueType fonts ממחיצת ה-windows.
עשיתי את זה לפי ההוראות, ואז ה-xfs החליט לשבות. לא מכיר יותר שום פונט.
לא היתה לי ברירה, עשיתי logout ו-login (מה שאתחל מחדש את ה-X), וראו זה פלא: הופ עובד.

אין לי מושג מה זה קשור. אין שם פונטים בכלל בהופ, הכל נראה לי מצוייר. אולי היה מספיק לאתחל מחדש את ה-X אחרי התקנת הפלאש (הראשונה, מזמן).

בכל אופן, עכשיו זה עובד. תודה לכם.
טרודי
 

שמחתי מוקדם מדי

הודעה שלא נקראהעל ידי טרודי » 19 אוקטובר 2003, 19:54

מסתבר שרק לפעמים זה עובד.
לפעמים זה עדיין נתקע, ובאותו מקום. ואחרי פעם אחת שנתקע, צריך לסגור ולפתוח את ה-X כדי שיהיה סיכוי שיעבוד.
גם ה"לעבוד" הוא חלקי: ה-sound נשמע כמו CD שמנגנים אותו ב-fast forward - קולות גבוהים וצלילים של "קפיצה". ניתן בקושי רב להבין מה נאמר.

כלומר: או שזה עובד עם sound דפוק, או שזה נתקע לגמרי.
אגב, אותו דבר בדיוק קורה גם לקונקרור, כך שזה נראה עניין של ה-plugin ולא של ה-browser עצמו.

יש למישהו רעיון?
טרודי
 

Re: שמחתי מוקדם מדי

הודעה שלא נקראהעל ידי Prognathous » 20 אוקטובר 2003, 09:29

מכיוון שהאתר עובד טוב במוזילה לחלונות, נראה שאכן הבעיה היא בפלאג-אין. אפשרויות:

1. לבדוק באתר של מקרומדיה אם קיים פלאג-אין חדש יותר ואם ידוע על בעיות מוכרות עם הגירסה ללינוקס.
2. לנסות גירסאות ישנות יותר של הפלאג-אין.
3. לנסות דפדפן מחלונות דרך שכבת התאימות WINE או אחת הגרסאות המסחריות שלו.
4. לנסות דפדפן מחלונות דרך אמולטור כגון Win4Lin או VMware.

אחת מהאפשרויות האלה לבטח תעבוד, השאלה אם העניין שווה את הטרחה ו/או את ההוצאה הכספית...

Prog.
סמל אישי של המשתמש
Prognathous

‎
 
הודעות: 941
הצטרף: 15 דצמבר 2002, 12:11


חזור אל SeaMonkey



מי מחובר

משתמשים הגולשים בפורום זה: Exabot [Bot] ו־0 אורחים