mozilla.org.il
דף ראשי
The Mozilla
Foundation
English
הצטרפות
פורום
חדשות מוזילה
כתיבה לפי התקן
Firefox
Thunderbird
תנאי הרשיון
תמיכה טכנית
שו"ת
וויקי
קישורים
הוראות למתרגמים
דווח על באג
יצירת קשר
חיפוש

SourceForge Logo

valid html 4.0

איך להשתמש ב-MozillaTranslator

ההוראות הבאות מתייחסות לגרסה 5.02. בצע את הצעדים הבאים:

קרא את דף הכלים לקבלת יותר מידע על MozillaTranslator. כפי שמצויין שם, יש להתקין את JRE 1.4 לפני הפעלת MT.

תחילה יש להשיג את הקובץ המכיל את חבילת השפה האנגלית, המכיל את המחרוזות האנגליות אותן יש לתרגם. קובץ זה, הנקרא en-US.jar, ניתן להשגה בשתי דרכים:

  1. אם התקנת את גרסת Mozilla אותה אתה מתרגם, תוכל למצוא אותו תחת התיקיה chrome הנמצאת תחת התיקיה בה התקנת את Mozilla. זו הדרך המומלצת, משום שכך תוכל לראות את מה אתה מתרגם.
  2. אם אינך רוצה להתקין את Mozilla, ניתן להשיג את חבילת השפה האנגלית מאתר ה-FTP של mozilla.org. משם, בחר את הגרסה בה אתה מעוניין, ומתוכה בחר את אחת מן הספריות windows/linux/mac-xpi. בספריה זו תמצא את הקובץ langenus.xpi, המכיל את החבילה האנגלית, בדומה לחבילת השפה העברית.

שים לב: עד גרסה 1.2b, היתה אי-התאמה בין תוכנם של שלושה קבצים בחבילת השפה האנגלית, כפי שהופצה עם גרסאות Mozilla עבור שלושת מערכות ההפעלה הנפוצות - Windows, Linux, ו-Mac. מסיבה זו, יש להוריד גרסה מסונכרנת של קבצים אלה: היכנס לאתר ה-FTP של mozilla.org, בחר את גרסת Mozilla אותה אתה מתרגם, היכנס לספריה בשם bug118140, והורד את הקבצים en-win/mac/unix.jar. ניתן להשתמש גם בקובץ en-US.jar המופיע שם, במקום בחבילת השפה האנגלית כפי שהוסבר לעיל. מגרסה 1.2 ומעלה (מאז תוקן הבאג) יש להשתמש באחת משתי הדרכים שצויינו בלבד.

עתה, יש להשיג את חבילת השפה האחרונה שתורגמה, וזאת כדי לחסוך את תרגום כל התוכנה מחדש בכל פעם. יתכן שקיבלת אותה מצוות התרגום. אם לא, השג אותה בדרך הבאה: חבילת השפה ארוזה גם היא בקובץ בעל סיומת xpi. שגם אותו ניתן למצוא באותו שרת ה-FTP של mozilla.org. בחר את הגרסה המתאימה, ומשם בחר את הקובץ. חבילת השפה העברית צריכה להיות בשם langheil.xpi.

פתיחת קבצי ה-xpi

קובץ xpi הוא למעשה קובץ zip רגיל, ששמו שונה. בתוך כל קובץ כזה ישנם מספר קבצים:

  • install.js: זהו קובץ JavaScript המתקין את חבילת השפה בדפדפן.
  • he-IL.jar: גם זה קובץ zip ששמו שונה. קובץ זה מכיל את הקבצים המכילים את המחרוזות המרכיבות את ממשק המשתמש, ואינן תלויות במערכת ההפעלה.
  • he-win.jar,‏ he-mac.jar,‏ he-unix.jar: קבצים אלה מכילים מחרוזות התלויות במערכת ההפעלה, כמו שמות מקשים, ורכיבים שמימושם שונה ממערכת הפעלה אחת לשניה.
  • IL.jar: קובץ חבילת האיזור. לא הכרחי, אך בדר"כ נמצא. ניתן גם להפיצו בחבילת איזור נפרדת. מכיל הגדרות וקישורים העשויים להשתנות ממדינה למדינה, ואת רוב הקישורים שיצרן המייצר דפדפן מבוסס Mozilla ירצה לשנות, כמו למשל האתר אליו מגיעים כאשר לוחצים על האנימציה בפינה העליונה של חלונות התוכנה השונים.
  • החל מגרסה 1.3, חבילת השפה מכילה גם גם קבצים אחרים, כמו קובץ סימניות המכיל גם קישורים לאתר של צוות התרגום, וכד'.
בעזרת winzip או כל תוכנה אחרת לניהול קבצי zip הוצא את קובצי ה-jar. מתוך קובץ ה-xpi. אין צורך לפתוח עוד את קובצי ה-jar.

יבוא קובץ JAR

תחילה יש ליבא את המחרוזות המקוריות באנגלית, ואח"כ לטעון את התרגום העברי של הגרסה הקודמת.

  1. הפעל את MozillaTranslator 5.
  2. מתפריט File בחר Manage Products.
  3. לחץ על Add בתיבת הדו-שיח הנפתחת.
  4. תקבל תיבת דו-שיח מפורטת, בה ניתן להגדיר את כל אחד מרכיבי החבילה.
    1. בתיבה Basic Information הכנס בשדה Name שם שרירותי שיסמן את החבילה עליה אתה עובד. כאן כל מרכיבי החבילה מנוהלים תחת שם אחד, ולכן כדאי לקבוע שם כללי, כמו למשל "moz1.1".
    2. בתיבה Platform neutral הכנס בשדה Jar file את הנתיב המלא אל הקובץ en-US.jar.
    3. התיבה Platform specefic (השגיאה במקור) מכילה את הקבצים התלויים במערכת ההפעלה. אם נתבקשת לתרגם קבצים אלה, או שעליך לתרגם אותם מסיבה אחרת, לחץ על Add.
      1. בשדה Name הכנס שם שיסמן את הקובץ אותו תגדיר. למשל, עבור הקובץ en-win.jar אפשר להכניס שם כמו "win32".
      2. בשדה Jar file הכנס את הנתיב המלא אל אחד מן הקבצים en-win.jar, en-mac.jar ו-en-unix.jar.
      3. בתפריט הגלילה Type בחר את מערכת ההפעלה אליה שייך הקובץ שציינת קודם.
      4. לחץ על OK.
    4. במידת הצורך, בתיבה Regional הכנס בשדה Jar file את הנתיב המלא אל הקובץ US.jar.
    5. תפקידה של התיבה Custum files הוא להוסיף קבצים חיצוניים, כמו קובץ סימניות עם סימניות לאתרים מקומיים, מנועי חיפוש מקומיים, ותרגום של סרגלים שבאים עם Mozilla. אין פה הרבה עבודה, ולכן חלק זה יטופל על ידי מרכז התרגום.
  5. לחץ על OK.
  6. החבילה שהגדרת אמורה להופיע עתה ברשימה המופיעה בתיבת הדו-שיח. לחץ על Exit.
  7. מתפריט File בחר Update Product. בחר מן הרשימה הנגללת את החבילה עליה אתה עובד, ולחץ על OK.
  8. תופיע רשימה של מחרוזות שהשתנו. דבר זה מאשר שייבאת את החבילה האנגלית בהצלחה. לחץ על OK.
  9. בדוק אם החבילה יובאה בהצלחה. מתפריט Edit בחר Chrome view. בתיבת הדו-שיח המופיעה, Show which columns, בחר במספר פריטים מן הרשימה (ניתן לבחור ביותר מפריט אחד על ידי לחיצה על מקש Ctrl בזמן לחיצה עם העכבר). פריטים אלה יוצגו בתצוגת ה-chrome מאוחר יותר. מומלץ לבחור את הפריטים Text: Original (טקסט מקורי) ו-Text: Translated (טקסט מתורגם). כדאי לבחור גם את Key (מפתח) ו-Keep original (שמור כמו המקור). השדה Text: Current מראה את הטקסט שירשם בקובץ כאשר תיצור את חבילת השפה, ולכן העמודה שלו תראה את הטקסט המתורגם אם קיים, ואת הטקסט המקורי אם לא הוכנס תרגום או שסימנת את העמודה keep. בשדה Locale הכנס את האותיות he-IL. לחץ על OK.
  10. בחר את השם שהכנסת בצעד 4.I עבור חבילה זו בצד שמאל, ופתח את אחד הרכיבים, לפי השמות שבחרת בצעד 4.III (פתיחה מתבצעת על ידי לחיצה כפולה על הפריט או לחיצה בודדת על הידית הקטנה שלידו). תחת כל רכיב תראה רכיבי משנה, שהם שמות ספריות הנמצאות בתוך קבצי ה-jar שייבאת קודם. פתח כל אחת מספריות אלה כדי לראות את הקבצים הנמצאים בתוכה.
  11. בחר את אחד הקבצים. בצד ימין תופיע רשימה של המחרוזות הנמצאות בתוך הקובץ והעמודות אותן בחרת בתיבה Show which column קודם. ניתן לערוך מחרוזת על ידי בחירתה ולחיצה על Alt+E.
  12. עתה, יש לייבא את התרגום העברי שביצעת בשלב הקודם. מתפריט Import בחר Import Translation.
    1. בתיבת הדו שיח המופיעה, בחר מתפריט הגלילה selected את אחד מרכיבי חבילת השפה. לדוגמה, אם נתת לחבילה את השם "moz1.1", בחר את moz1.1 >> Neutral כדי ליבא את התרגום של en-US.jar.
    2. בשדה File הכנס את הנתיב המלא אל קובץ ה-jar המתאים לחלק זה של החבילה. מול en-US.jar יש לייבא את he-IL.jar (אותו הוצאת מחבילת השפה, או שקיבלת ממנהל צוות התרגום). באופן דומה, מול הרכיב של Windows טען את he-win.jar, וכן הלאה, במידת הצורך.
    3. בשדה Locale הכנס he-IL.
  13. עתה חזור על צעד 9 לעיל ובדוק אם כל המחרוזות מתורגמות.
  14. שמור את עבודך על ידי בחירת Save Glossary מתפריט File.
3 2 1 הבא>>
Copyright © 1998-2003 The Mozilla Organization
and Hebrew localization team.
עודכן לאחרונה: 17/04/08