הכנת חבילת שפה עברית

מתוך וויקי
קפיצה אל: ניווט, חיפוש

חבילת שפה היא סוג של הרחבה, המתרגמת את ממשק המשתמש (תפריטים, תיבות דו שיח, וכו') לשפה אחרת. בעבר, לכל גרסה של Mozilla Suite שוחררו גם גרסאות מתורגמות מראש, וגם חבילות שפה שאיפשרו להוסיף תרגום על הגרסה האנגלית (או על כל גרסה אחרת, לצורך העניין). למרות שטכנית ניתן להכין חבילת שפה גם עבור Firefox, קרן מוזילה לא משחררת באופן רשמי חבילות שפה עבורו, אלא רק גרסאות מתורגמות מראש, מתוך הנחה שרוב המשתמשים ממילא יהיו מעוניינים רק בגרסה בשפה אחת הנוחה להם. עם הפסקת הפיתוח של Mozilla Suite והפסקת התמיכה בו, השימוש העיקרי של חבילות שפה הוא עבור SeaMonkey, אם כי יתכן שגם דפדפן זה יפסיק להשתמש בהן באופן רשמי בעתיד.

עם זאת, גם כדי ליצור גרסה מתורגמת מראש נוח להשתמש ב-MozillaTranslator, והמידע במאמר זה (שטרם הושלם) יכול לעזור ללמוד להשתמש בו.

איך להשתמש ב-MozillaTranslator

ההוראות הבאות מתייחסות לגרסה 5.20. בצע את הצעדים הבאים:

קרא את דף הכלים לקבלת יותר מידע על MozillaTranslator. כפי שמצויין שם, יש להתקין את JRE 1.4 לפני הפעלת MT.

תחילה יש להשיג את הקבצים המכילים את חבילת השפה האנגלית, המכילה את המחרוזות האנגליות אותן יש לתרגם. קבצים אלה הם en-US.jar,‏ en-mac.jar,‏ en-unix.jar,‏ en-win.jar,‏ ו-US.jar. ניתן להשיגם בשלוש דרכים:

  1. אם התקנת את גרסת Mozilla אותה אתה מתרגם, תוכל למצוא אותם תחת התיקייה chrome הנמצאת תחת התיקייה בה התקנת את SeaMonkey. זו הדרך המומלצת, משום שכך תוכל לראות את מה אתה מתרגם.
  2. אם אינך רוצה להתקין את SeaMonkey, ניתן להשיג את חבילת השפה האנגלית מאתר ה-FTP של mozilla.org. משם, בחר את הגרסה בה אתה מעוניין, ומתוכה בחר את אחת מן הספריות windows/linux/mac-xpi. בספריה זו תמצא את הקובץ langenus.xpi, המכיל את ארבעת הקבצים הראשונים, ואת הקובץ regus.xpi, המכיל את הקובץ US.jar.
  3. ניתן להוציא את חבילת השפה מקובץ ההתקנה של הגרסה האנגלית, בעזרת mozip או mozip.NET. הוצא מתוכו את שני קבצי ה-XPI כמו בסעיף הקודם.

עתה, יש להשיג את חבילת השפה האחרונה שתורגמה, וזאת כדי לחסוך את תרגום כל התוכנה מחדש בכל פעם. יתכן שקיבלת אותה מצוות התרגום. אם לא, השג אותה בדרך הבאה:

חבילת השפה ארוזה גם היא בקובץ בעל סיומת xpi. שגם אותו ניתן למצוא באותו שרת ה-FTP של mozilla.org, תחת התיקייה המתאימה למספר הגרסה הרצוי, ותחת התיקייה contrib-localized שתחתיה. חבילת השפה העברית צריכה להיות בשם seamonkey-[version].he-IL.langpack.xpi כאשר [version] מוחלף במספר הגרסה.

פתיחת קבצי ה-xpi

קובץ xpi הוא למעשה קובץ zip רגיל, ששמו שונה. בתוך כל קובץ כזה ישנם מספר קבצים:

  • install.js: זהו קובץ JavaScript המתקין את חבילת השפה בדפדפן.
  • he-IL.jar: גם זה קובץ zip ששמו שונה. קובץ זה מכיל את הקבצים המכילים את המחרוזות המרכיבות את ממשק המשתמש, ואינן תלויות במערכת ההפעלה.
  • he-win.jar,‏ he-mac.jar,‏ he-unix.jar: קבצים אלה מכילים מחרוזות התלויות במערכת ההפעלה, כמו שמות מקשים, ורכיבים שמימושם שונה ממערכת הפעלה אחת לשניה.
  • IL.jar: קובץ חבילת האיזור. לא הכרחי, אך בדר"כ נמצא. ניתן גם להפיצו בחבילת איזור נפרדת. מכיל הגדרות וקישורים העשויים להשתנות ממדינה למדינה, ואת רוב הקישורים שיצרן המייצר דפדפן מבוסס Mozilla ירצה לשנות, כמו למשל האתר אליו מגיעים כאשר לוחצים על האנימציה בפינה העליונה של חלונות התוכנה השונים.
  • החל מגרסה 1.3, חבילת השפה מכילה גם גם קבצים אחרים, כמו קובץ סימניות המכיל גם קישורים לאתר של צוות התרגום, וכד'.

בעזרת winzip או כל תוכנה אחרת לניהול קבצי zip הוצא את קובצי ה-jar. מתוך קובץ ה-xpi. אין צורך לפתוח עוד את קובצי ה-jar.

יבוא קובץ JAR

תחילה יש ליבא את המחרוזות המקוריות באנגלית, ואח"כ לטעון את התרגום העברי של הגרסה הקודמת.

SeaMonkey מכיל גם קבצי שפה בשני מקומות נוספים: קבצי השפה של כלי דיווח האתרים (הזמין מתפריט עזרה) נמצאים בקובץ reporter.jar, וקבצי השפה של התמיכה במשתמש נודד (הנמצאת בחלון ההעדפות) נמצאים בקובץ sroaming.jar. קבצים אלה נמצאים בתיקייה chrome לאחר ההתקנה, או בקבצים reporter.xpi ו-sroaming.xpi בהתאמה, הנמצאים באותו שרת FTP כאמור. כדי לוודא שרכיבים אלה יותקנו כראוי ויתורגמו כאשר חבילת השפה העברית תהיה בשימוש, יש לצרף אותם אל הקובץ en-US.jar. הוצא מקבצים אלה את כל הקבצים הנמצאים תחת התיקייה locale והוסף אותם לקובץ en-US.jar, תוך שמירה על מבנה התיקיות, לפני שאתה מייבא אותו אל MozillaTranslator.

  1. הפעל את MozillaTranslator 5.
  2. מתפריט File בחר Manage Products.
  3. לחץ על Add בתיבת הדו-שיח הנפתחת. תקבל תיבת דו-שיח מפורטת, בה ניתן להגדיר את כל אחד מרכיבי החבילה.
    1. בתיבה General Information הכנס בשדה Name שם שרירותי שיסמן את החבילה עליה אתה עובד. כאן כל מרכיבי החבילה מנוהלים תחת שם אחד, ולכן כדאי לקבוע שם כללי, כמו למשל "moz1.1".
    2. בחר באפשרות JAR based כדי לתרגם על בסיס קבצי JAR. מתרגמים של Firefox ירצו להשתמש באפשרות CVS based.
    3. בתיבה JAR info panel הכנס בשדה Platform Neutral JAR file את הנתיב המלא אל הקובץ en-US.jar.
    4. השדה Platform JAR files מכיל את הקבצים התלויים במערכת ההפעלה. אם נתבקשת לתרגם קבצים אלה, או שעליך לתרגם אותם מסיבה אחרת, לחץ על Add.
      1. בשדה Name הכנס שם שיסמן את הקובץ אותו תגדיר. למשל, עבור הקובץ en-win.jar אפשר להכניס שם כמו "win32".
      2. בשדה Jar file הכנס את הנתיב המלא אל אחד מן הקבצים en-win.jar, ‏ en-mac.jar ו-en-unix.jar.
      3. בתפריט הגלילה Type בחר את מערכת ההפעלה אליה שייך הקובץ שציינת קודם.
      4. לחץ על OK.
    5. במידת הצורך, בשדה Regional JAR files הכנס את הנתיב המלא אל הקובץ US.jar.
    6. תפקידו של השדה Custom files הוא להוסיף קבצים חיצוניים, כמו קובץ סימניות עם סימניות לאתרים מקומיים, מנועי חיפוש מקומיים, ותרגום של סרגלים שבאים עם Mozilla. בגרסאות האחרונות של MT החלק הזה לא עובד היטב, ועדיף להוסיף קבצים אלה ידנית מאוחר יותר.
  4. לחץ על OK.
  5. החבילה שהגדרת אמורה להופיע עתה ברשימה המופיעה בתיבת הדו-שיח. לחץ על Exit.
  6. מתפריט File בחר Update Product. בחר מן הרשימה הנגללת את החבילה עליה אתה עובד, ולחץ על OK.
  7. תופיע רשימה של מחרוזות שהשתנו. דבר זה מאשר שייבאת את החבילה האנגלית בהצלחה. לחץ על OK.
  8. בדוק אם החבילה יובאה בהצלחה. מתפריט Edit בחר Chrome view. בתיבת הדו-שיח המופיעה ,Show which columns, בחר במספר פריטים מן הרשימה (ניתן לבחור ביותר מפריט אחד על ידי לחיצה על מקש Ctrl בזמן לחיצה עם העכבר). פריטים אלה יוצגו בתצוגת ה-chrome מאוחר יותר. מומלץ לבחור את הפריטים Text: Original (טקסט מקורי) ו-Text: Translated (טקסט מתורגם). כדאי לבחור גם את Key (מפתח) ו-Keep original (שמור כמו המקור). השדה Text: Current מראה את הטקסט שירשם בקובץ כאשר תיצור את חבילת השפה, ולכן העמודה שלו תראה את הטקסט המתורגם אם קיים, ואת הטקסט המקורי אם לא הוכנס תרגום או שסימנת את העמודה keep. בשדה Locale הכנס את האותיות he-IL. לחץ על OK.
  9. בחר את השם שהכנסת בצעד 3.1 עבור חבילה זו בצד שמאל, ופתח את אחד הרכיבים. פתיחה מתבצעת על ידי לחיצה כפולה על הפריט או לחיצה בודדת על הידית הקטנה שלידו. תחת כל רכיב תראה רכיבי משנה, שהם שמות ספריות הנמצאות בתוך קבצי ה-jar שייבאת קודם. פתח כל אחת מספריות אלה כדי לראות את הקבצים הנמצאים בתוכה.
  10. בחר את אחד הקבצים. בצד ימין תופיע רשימה של המחרוזות הנמצאות בתוך הקובץ והעמודות אותן בחרת בתיבה Show which column קודם. ניתן לערוך מחרוזת על ידי בחירתה ולחיצה על Alt+E.
  11. עתה, יש לייבא את התרגום העברי שביצעת בשלב הקודם. מתפריט Import בחר Import Translation from JAR. מתרגמי Firefox יבחרו Import Translation from CVS.
    1. בתיבת הדו שיח המופיעה, בחר מתפריט הגלילה Select platform את אחד מרכיבי חבילת השפה. לדוגמה, אם נתת לחבילה את השם "moz1.1", בחר את moz1.1 >> Neutral כדי ליבא את התרגום של en-US.jar.
    2. בשדה File הכנס את הנתיב המלא אל קובץ ה-jar המתאים לחלק זה של החבילה. מול en-US.jar יש לייבא את he-IL.jar (אותו הוצאת מחבילת השפה, או שקיבלת ממנהל צוות התרגום). באופן דומה, מול הרכיב של Windows טען את he-win.jar, וכן הלאה, במידת הצורך.
    3. בשדה Locale הכנס he-IL.
  12. עתה חזור על צעד 8 לעיל ובדוק אם כל המחרוזות מתורגמות.
  13. שמור את עבודך על ידי בחירת Save Glossary מתפריט File.

ביצוע התרגום

דגשים לתרגום טוב

הרשימה הבאה מפרטת מספר דגשים והצעות לשמירת איכות תרגום גבוהה. יש להשתמש בהנחיות אלו עד כמה שניתן, על מנת שהתוכנה המתורגמת תיראה טוב לפחות כמו התוכנה המקורית.

  • השתמש באגרון המילים המופיע כאן . אם מילה שאתה צריך אינה מופיעה בו, כדאי להיעזר באחד המקורות המופיעים בתחתית האגרון, או במילון אנגלי-עברי טוב.
  • כאשר יש יותר מדרך אחת לתרגם מילה, תחילה בדוק אם המילה כבר תורגמה במקום אחר, על ידי חיפוש מתפריט Edit של MozillaTranslator (להלן MT). עקביות התרגום חשובה מאוד למראה מקצועי של התוכנה.
  • מרבית המחרוזות שתראה כבר יהיו מתורגמות, וזאת מכיוון שהשינויים במימשק בין גירסה אחת לשניה של Mozilla אינם גדולים (לדוגמה, במעבר מתרגום גירסה M18, שפורסמה באוקטובר 2000, לתרגום גירסה 0.9.4, שפורסמה בספטמבר 2001, כשני שלישים עד שלושה רבעים כבר היו מתורגמים). עם זאת, מדי פעם מתבצעים שינויים בניסוח מחרוזות, בדר"כ כדי לעשותן מובנות יותר למשתמש. מסיבה זו, גם אם כבר קיים תרגום, יש לבדוק אותו ולוודא שהוא נכון, ולעדכן במידת הצורך.
  • בדר״כ המילים true או false אינן משמשות במימשק של Mozilla, אלא מהוות הנחייה עבור Mozilla לגבי צורת הצגה של מרכיבי ממשק מסויימים. לכן, עדיף שלא לתרגם אותם, אלא לסמן אותם כ-keep (שמור כמו המקור). במקרה של ספק, ניתן לבדוק אם יש הערת תרגום המתייחסת לערך זה בקובץ עצמו בעזרת Unipad, כפי שמוסבר בחלק הבא.
  • אם נתקלים במילים מחוברות, שהאות הראשונה שלהן קטנה (לדוגמה, malformedURI או netReset), אין לתרגם אותן. אלה מילים המשמשות כשמות קבצים ולשימושים אחרים, ואינן חלק מן הממשק.
  • מפתחות (keys) המסתיימים ב-accesskey. או aKey. מציינים אותיות המשמשות בצירופי הקיצור Alt+x. אותיות אלה מסומנות בדר"כ במימשק בקו תחתי, והן בעלות מפתח עם תחילית זהה למפתח של המחרוזת אליה הן מתייחסות. יש לוודא שהאות לקוחה מתוך המחרוזת המתאימה.
  • מפתחות המסתיימים ב-key. או .controlkey. או keybinding. מציינים אותיות המשמשות בצירופי הקיצור Ctrl+x (או Cmd+x ב-Mac OS X). אין לתרגם מפתחות אלה, למרות שטכנית זה אפשרי, כדי לא לבלבל את המשתמשים העוברים מהגרסה האנגלית לגרסה העברית.
  • לעיתים תיתקל במחרוזות שהן מספר בלבד, לעיתים בצירוף המילה width או hight. אלה הנחיות לקביעת רוחב תיבות דו-שיח ורכיבים אחרים, בהתאם לרוחב שנדרש לכל שפה. במידת הצורך, לכל היותר יש לשנות את הערכים המספריים, אך ברוב המיקרים אין צורך לשנות את הערכים, ובוודאי שאין לתרגם את המילים, אם קיימות.
  • שמות מותגים או רכיבים, כגון Windows,‏ Netscape,‏ Navigator,‏ Communicator,‏ Composer וכל שם של תוכנה או חלק ממנה, יושאר בצורתו האנגלית, וזאת כדי להימנע משגיאות בהבנה כתוצאה מדרכים שונות הנהוגות בכתיבת שמות תוכנות פופולריות.
  • למרות שעקרונית אין בכך צורך, כדאי מאוד, לפתוח גם את קבצי ה-jar אל הדיסק, (וכדאי לעשות זאת אל הספריה הראשית תוך שמירת מבנה התיקיות, להקלת העבודה בשלבים מאוחרים יותר). למשל, לעיתים קרובות הקבצים מכילים הערות תרגום (מסומנות במילים LOCALIZATION NOTE) המסבירות כיצד לתרגם מחרוזות מסויימות, ולכן, במקרה של ספק, ניתן לגשת אל הקובץ ולראות אם קיימת הערת תרגום. בנוסף, מחרוזות המתפרסות על מספר שורות לעיתים אינן מוצגות היטב ב-MT, ויש לראות את המחרוזת המקורית בקובץ שלה.
  • התמיכה בכיווניות ימין לשמאל אינה מושלמת ב-Java, ויתכן שסדר הכתיבה של סימנים מסויימים, בעיקר כאלה המשמשים גם בעברית וגם באנגלית, יתהפך. הכלל הוא, שיש להקליד את התוים בסדר בו אתה רוצה שיראו על המסך, גם אם כרגע הם נראים הפוך, כפי שהיית כותב אותם במעבד תמלילים (כלומר, מילים באנגלית מוקלדות החל מהאות הראשונה, השמאלית, של המילה). בכל מקרה, אין לנסות להקליד את הסימנים בסדר הפוך כדי שיראו טוב ב-MT, משום שהם יראו הפוך שוב במימשק של Mozilla.
  • במקומות מסויימים תראה את הסימן "&" (ampersand) באמצע מילה. מקומות אלה משתמשים בקריאות של מערכת ההפעלה (בעיקר של Windows) להצגת המימשק, והאותיות שאחרי הסימן מסומנות בקו תחתי במימשק. כאן יש להקפיד שאין מצב בו אותה האות מסומנת בקו תחתי (כלומר יש לפניה "&") בשני מקומות שונים בקובץ.
  • לעיתים מופיע הצירוף "n\". זהו סימן לסוף שורה ותחילת שורה חדשה עבור Mozilla, והוא מופיע בדר"כ במקומות בהם המחרוזת מחולקת למספר שורות. סימן זה לא צריך להופיע ב-MT, ובכל מקום בו הוא מופיע, יש למחוק אותו ולהקיש על מקש Enter במקום. אם הוא מופיע פעמיים או יותר ברציפות, יש להקיש על Enter כמספר הפעמים שהוא מופיע. MT מוסיף אותו אוטומטית כאשר הוא מייצר את חבילת השפה, בסוף העבודה.
  • בשני מקומות, מופיע מספר הגירסה של הדפדפן לו מיועדת חבילת השפה: בקובץ הראשי, en-US.jar, בקובץ global/brand.dtd במפתח lang.version, ובקובץ חבילת האיזור, US.jar, בקובץ global-region/region.dtd במפתח content.version. בשני מקומות אלה יש לסמן את keep, כדי שגם בתרגום ישמר אותו מספר גרסה. שינוי במספר הגירסה כאן לעומת המספר המקורי יהפוך את החבילה לבלתי שמישה.
  • הקובץ US.jar: אם החלטת לתרגם קובץ זה, שים לב שלא לשנות את הכתובות השונות המופיעות בו. שינוי של כתובת כזו, כבר יהפוך את חבילת השפה מתרגום למיתוג מחדש של הדפדפן (כמו המיתוג של מותג Netscape).

הדברים החשובים ביותר בתרגום הם דיוק, עקביות ורשמיות (פורמליות):

דיוק
אם אינך בטוח ב-100% במשמעות של מילה, אל תמציא. חפש אותה באגרון או במילון אנגלי עברי טוב.
עקביות
אלא אם קיימת משמעות אחרת בהתאם להקשר, מילה תמיד תתורגם באותו אופן בכל הופעותיה.
רשמיות
כאשר אתה מתרגם, חשוב שאתה מנסח עתירה לבג"ץ. תוכנה אינה מכתב לחבר, וכדי להיראות מקצועית, עליה להשתמש בשפה רשמית ונכונה תחבירית ולשונית. שגיאות כתיב בלתי מתקבלות על הדעת. עגה (סלנג) אינה מתקבלת. יש להימנע משגיאות תחביריות. (בהקשר זה, שים לב שבעברית יש יותר מילות חיבור וקישור מאשר באנגלית, כמו "על" ו"את", ויש לזכור להוסיף אותן במקומות המתאימים.)

מקשי קיצור: בבחירת מקשי הקיצור (האותיות המסומנות בקו תחתי בממשק, בדר"כ מסומנות במפתחות עם סיומת accesskey בחבילת השפה) יש לבחור באותיות יו"ד, ו"ו ונו"ן סופית רק אם אין ברירה אחרת. זאת מכיוון שהרוחב הקטן של אותיות אלה מקשה על הבחנה בקו התחתי.

עבודה עם MozillaTranslator

העבודה עם MozillaTranslator היא בעיקרה די פשוטה. היא נעשית בחלון Chrome view הנפתח בצעד 8 בשלב הקודם. בחר את אחד הפריטים בצד ימין של חלון Chrome View. אם בחרת להציג את הפריט Text: Translated, תוכל ללחוץ עליו לחיצה כפולה כדי לערוך אותו. בכל מקרה, ניתן ללחוץ על המקשים Ctrl+E כדי לפתוח את חלון העריכה. בחלק העליון תראה את הטקסט המקורי. בחלק התחתון תראה את הטקסט המתורגם, אם קיים. אם אין טקסט מתורגם, או שהתרגום אינו נכון, תוכל להכניס תרגום חדש. בלשונית Advanced תוכל לראות פרטים נוספים על המחרוזת אותה אתה מתרגם. לשמירת השינויים, לחץ על Close כדי לסגור את חלון העריכה, או Next או Previous כדי לעבור ישירות אל המחרוזת הבאה או הקודמת, בהתאמה. השינויים ישמרו אוטומטית, אך יש לשמור אותם לקובץ לפני סגירת התוכנה.

כדי לשמור את העבודה לאחר שתירגמת חלק מן המחרוזות, בחר Save Glossary מתפריט File.‏ MT יצור קובץ בשם glossary.zip בתיקיה בה הוא נמצא. קובץ זה מכיל את כל המחרוזות שתירגמת.

בתום עבודת התרגום, אם אתה מתרגם רק חלק אחד אותו יש לרכז במקום אחר עם חלקים עליהם עובדים מתרגמים אחרים, בשלב זה ייצא את עבודתך על ידי בחירת Export partial glossary מתפריט Export. בחר את הרכיב או הרכיבים אותם תירגמת, וצור את הקובץ. שלח אותו אל מי שמרכז את התרגום של הגירסה עליה אתה עובד. אם אתה המתרגם היחיד, או שאתה האדם המרכז את העבודה, ואתה צריך ליצור חבילת שפה שלמה בעצמך, המשך הלאה.

יצוא חבילת שפה

עתה, יש ליצא חבילת שפה. עקוב אחר הצעדים הבאים.

  1. מתפריט Export בחר XPI Install. בתיבת הדו-שיח המופיעה, הכנס את הערכים הבאים:
  2. בשדה Locale הכנס, ניחשת נכון, he-IL.
  3. בשדה File הכנס את הנתיב המלא אל קובץ חבילת השפה שתיצור. יש לתת לקובץ את הסיומת xpi.
  4. בשדה display Name הכנס את שם חבילת השפה. שם זה יוצג למשתמש בהעדפות של Mozilla, ומקובל לרשום בו את שם השפה, בצירוף המדינה, למשל Hebrew (IL)‎.
  5. בשדה Author ניתן להכניס את שמות המתרגמים, אם כי המשתמש לא יראה שמות אלה. מידע זה ישמר בתוך חבילת השפה.
  6. בשדה Preview URL ניתן להכניס כתובת אתר בו ניתן לראות צילומי מסך של Mozilla מתורגמת, או קישור ישיר אל קובץ תמונה של צילום מסך, אך הקישור או התמונה אינם מוצגים למשתמש אלא נשמרים בתוך חבילת השפה בלבד.
  7. בשדה Version יש להכניס את מספר הגירסה המדוייק של Mozilla אליו מיועדת חבילת השפה, כפי שהוסבר בנקודה הלפני אחרונה של דגשים לתרגום טוב לעיל.
  8. בתיבה Select platforms and regions בחר את רכיבי החבילה שברצונך לכלול. חבילה טובה צריכה לכלול לפחות את הרכיבים Neutral,‏ Windows,‏ Unix ו-Mac. את רכיב Region‏ (US.jar) ניתן לכלול גם, או ליצור חבילת איזור נפרדת.
  9. לחץ על OK.

בשלב זה כבר יש לך חבילת שפה שניתן להתקינה, אך היא עדיין אינה מושלמת. בין היתר, השם שהכנסת קודם בצעד 4, בשדה display Name, משמש גם בחבילת האיזור, אם צירפת אותה לחבילה, ועדיף לתת לחבילת האיזור שם נפרד. בנוסף, אף כי ניתן לתרגם את קבצי העזרה (רכיב help של platform neutral) בעזרת MT, קל יותר להשתמש בעורך טקסט חיצוני לצורך זה. המשך לשלב הבא כדי להשלים את החבילה.

הוראות שימוש בעורך יוניקוד

העבודה עם עורך יוניקוד (כמו Unipad) מתחילה לאחר שהסתיימה העבודה עם MozillaTranslator וכבר קיימת חבילת שפה עובדת, לפחות חלקית.

קבצי חבילת השפה שמורים בפורמט הקרוי יוניקוד. זהו פורמט מורחב, המאפשר, בניגוד לפורמט ASCII או ANSI המשמש ב-DOS ו-Win9x, לשמור בטבלת אותיות אחת סט תוים של יותר משפה אחת או שתיים. ישנם מספר סוגים של קידוד Unicode, וקבצי חבילת השפה משתמשים בשניים מהם, כפי שמוסבר כאן (היית אמור לקרוא דף זה מזמן).

  • קבצי ‎*.dtd שמורים בקידוד UTF-8.
  • קבצי ‎*.properties שמורים בקידוד Escape-Unicode, המכונה ב-Unipad בשם ASCII-UNC(\u)‎.

Unipad יודע לפתוח ולשמור קבצים במיגוון סוגי יוניקוד, וזו הסיבה שאני משתמש בו. לחלופין, ניתן להשתמש בכל עורך יוניקוד אחר היודע לטפל בשני סוגים אלה. תוכנת השירות Notepad (פנקס רשימות) המצורפת למערכות Windows 2000 ו-Windows XP (אך לא זו המצורפת לגירסאות קודמות של Windows!) יודעת לשמור בתבנית UTF-8, אך לא בתבנית Escape-Unicode, ולכן לא תועיל כאן.

שיטת העבודה

  1. בעזרת WinZip (או תוכנה אחרת לניהול קבצי zip) פתח את קובץ חבילת השפה שיצרת קודם (קובץ ה-xpi), והוצא מתוכו את הקובץ he-IL.jar.
  2. פתח את הקובץ he-IL.jar והוצא מתוכו את כל הקבצים בשם contents.rdf לתיקיה הראשית של הדיסק שלך (\:C) תוך שמירה על מבנה התיקיות ( ב-winzip יש לסמן את Use folder names). חשוב לפרוס לתיקיה הראשית לצורך האריזה מחדש מאוחר יותר. לאחר הפריסה תקבל בתיקיה הראשית תיקיה בשם locale, ובתוכה תיקיה בשם he-IL. אתה אמור לקבל מבנה כזה:
    מבנה עץ
  3. חזור על צעד 2, הפעם עם הקובץ en-US.jar, הנמצא בתיקיה chrome הנמצאת תחת התיקיה בה התקנת את Mozilla. הוא יפתח לתיקיה בשם en-US תחת locale.
  4. הפעל את unipad, ופתח את הקובץ עליו ברצונך לעבוד מתוך קבצי החבילה העברית (הנמצאת תחת תיקית C:\locale\he-IL). כדאי לפתוח גם את הקובץ המקביל בחבילת השפה האנגלית ולהשוות בין שניהם. כדי לראות עברית בכיוון הנכון ולא הפוך, יש לסמן בתפריט Options, פקודת Default Options, לשונית Bidirectionality, את האפשרות Full Support.
  5. בכל תיקיה ראשית בתוך קובץ חבילת השפה קיים קובץ בשם contents.rdf.‏ MT5 מייצר קבצים אלה באופן אוטומטי, עם מלוא המידע האפשרי. חלק ממידע זה הכנסת כאשר יצאת את החבילה מתוך MT. ככלל אצבע, יש לדאוג שמבנה קבצי contents.rdf בכל אחד מרכיבי חבילת השפה יהיה זהה לקובץ המקביל בחבילה האנגלית המקורית. תחת הכותרת <!-- locale information --> יש לדאוג שאותן שורות יופיעו בחבילה האנגלית והחבילה שיצרת. במרבית המקרים, פירוש הדבר הוא שיהיה עליך למחוק חלק מן השורות. המקום היחיד בו כל השורות נדרשות הוא ברכיב global. כמובן, יש לדאוג שערכי הפרמטרים המופיעים בכל שורה יתאימו לחבילה שלך. דוגמה לחלק זה:

<monospace dir="ltr"><RDF:Description about="urn:mozilla:locale:he-IL"

     chrome:displayName="Hebrew language pack"
     chrome:author="mozilla.org.il"
     chrome:name="he-IL"
     chrome:localeVersion="1.0.0final"
     chrome:previewURL=""></monospace>

באופן כללי, ניתן לומר שיש לדאוג שמבנה קבצי contents.rdf בכל אחד מרכיבי חבילת השפה יהיה זהה לקובץ המקביל בחבילה האנגלית המקורית, למעט החלפת en-US בצירוף he-IL, והחלפת ערך השורה displayName בשם החבילה העברית, במקום השם English (US)‏ המופיע בחבילה האנגלית, במקומות בהם הוא מופיע.

אם אתה מוחק את השורה האחרונה (chrome:previewURL="">‎ בדוגמה זו) שים לב שלא לשכוח לסגור מחדש את הסוגר המשולש בסוף הקטע ("<").

  1. בקבצי contents.rdf של חבילת האיזור יש לשנות את ערך chrome:displayName לשם שיבהיר שמדובר בחבילת תוכן ולא שפה, כמו למשל "Israel Region".
  2. שים לב שתקן יוניקוד קובע לא רק את סימול האותיות בקובץ, אלא גם מרכיבים רבים אחרים. למשל, את הדרך בה מסומן סוף השורה. במרבית הקבצים הנמצאים בתוך קבצי ה-jar סוף השורה מסומן בשיטת DOS, כלומר עם CR+LF (סוף שורה והזנת שורה חדשה). עם זאת, הקבצים הנמצאים בקבצי ה-jar התלויים בקבצי חבילת השפה משתמשים בסימון המקובל במערכות ההפעלה אליהם הם מתייחסים: הקבצים בתוך en-win.jar משתמשים בשיטת DOS הנ"ל, הקבצים בתוך en-unix.jar משתמשים בשיטת UNIX (כלומר LF, שורה חדשה, בלבד), והקבצים בתוך en-mac.jar משתמשים בשיטת Mac (כלומר CR, סוף שורה, בלבד). כאשר עורכים את קבצי contents.rdf של הגירסאות העבריות של קבצים אלה (he-win.jar וכו'), מומלץ לוודא שסוף השורה מסומן בצורה הנכונה, כדי לצמצם את האפשרות לבעיות בתרגום Mozilla על מערכות ההפעלה השונות: ב-Unipad, בחר File Properties מתפריט File, או בחר File Properties מסרגל הכלים.
  3. לאחר שתיקנת קובץ (או מספר קבצים באותה תיקיה) עדכן את הקובץ he-IL.jar: פתח אותו (שוב, עם winzip או תוכנה מקבילה), והוסף לו את הקובץ המתוקן תוך שמירת מבנה התיקיות (ב-winzip יש לסמן בחלון Add את Save full path info בריבוע Folders, ולבחור רמת דחיסה Normal). מומלץ להתקין את חבילת השפה, אפילו אם היא עדיין מכילה שגיאות, וזאת כדי לראות בזמן אמיתי את התיקון. במקרה זה, העדכון יעשה ישירות על הקובץ he-IL.jar הנמצא בספריה chrome כפי שהוסבר בצעד 3.
  4. כמובן, באופן דומה, יש לתקן את קבצי contents.rdf הנמצאים בקבצי ה-jar התלויים במערכת ההפעלה, he-win.jar,‏ he-mac.jar ו-he-unix.jar.

הקובץ intl.css

החל מגרסה 0.9.8 של Mozilla התווסף לרכיב global של חבילת השפה קובץ בשם intl.css. כפי שאפשר לנחש משמו, זהו קובץ CSS המשפר את התמיכה בשפות בינלאומיות (כלומר, שאינן אנגלית). אנו משתמשים בקובץ זה כדי להורות ל-Mozilla להפוך את כיוון המימשק לכיוון ימין-לשמאל. דבר זה נעשה בעזרת הוספת פקודות CSS לקובץ זה, כפי שמפורט בדוגמה הבאה:

הקובץ המקורי נראה כך: <monospace dir="ltr"> /*

* This file contains all localizable skin settings such as 
*   font, layout, and geometry
*/

window {

 font: 3mm tahoma,arial,helvetica,sans-serif;

}</monospace>

תחילה, נוסיף את הפקודות להפיכת המימשק:

<monospace dir="ltr"> /*make UI RTL */

window,dialog,wizard,page { direction: rtl; }

menu { direction: rtl; }

outliner { direction: rtl; } </monospace>

עתה, נוסיף פקודת נגד, אשר תשמור את כיוון הטקסט בשורת הכתובת בכיוון שמאל לימין, משום שכתובות של אתרים הן באנגלית. שים לב שכאן הכיוון הואltr ‏ (Left To Right)‎ ולא rtl כמו קודם:

<monospace dir="ltr"> /*************************************

    • Fix address bar directionality **
                                                                          • /

/*make address bar remain LTR */

  1. urlbar { direction: ltr !important; }

</monospace>

אך אנו רוצים שהחיפוש משורת הכתובת במנועי חיפוש עדיין יהיה בכיוון ימין-לשמאל (הכוונה היא לאפשרות להכניס ערך לחיפוש בשורת הכתובת, ולבחור "חפש ב-Google את "ערך חיפוש" בתחתית התפריט הנגלל מתחת לשורת הכתובת). לשם כך נכניס את הפקודות הבאות:

<monospace dir="ltr"> /* leave search from address bar in RTL */

  1. urlbar .autocomplete-search-engine

{ direction: rtl !important; }

/***** End address bar fix ******/ </monospace>

לשונית "קוד מקור <HTML>" בעורך Composer מכילה קוד HTML שצריך להיות בכיוון שמאל לימין. נוסיף את השורות הבאות, שידאגו שהכרזת סוג התוכן וכן התוכן עצמו יהיו בכיוון הנכון:

<monospace dir="ltr"> /*

* keep Composer <HTML> Source tab LTR
*/
  1. content-source,
  2. doctype-text { direction: ltr; }

</monospace>

בדיקת העבודה

כדאי לבדוק, בעיקר בשלב 5, שהוא הארוך ביותר, אם התיקון אכן פועל כהלכה, וכן שהתרגום מדוייק ונכון להקשר. ניתן לעשות זאת על ידי התקנת חבילת השפה שנוצרה מ-MT בשלב הקודם, כפי שהוסבר לעיל בצעד 9. ניתן לבצע את הבדיקה באחת משתי דרכים:

  1. להפעיל את Mozilla לאחר עדכון הקובץ ולראות את חלק הממשק שתורגם.
  2. לא תמיד ניתן למצוא או להפעיל את רכיב הממשק שתורגם זה עתה, ואז ניתן לפתוח את הקובץ comm.jar מתיקיית chrome ולטעון לדפדפן (בעזרת פקודת קובץ|פתח קובץ) את קבצי ה-xul המקבילים לקבצי ה-dtd שתורגמו, ולראות אם הם פועלים, ואם התרגום טוב.

בסוף העבודה יש לארוז את חבילת השפה לקובץ XPI כדי שגם אחרים יוכלו להתקינה: צור בספריה הראשית תיקייה בשם bin, ותחתיה צור ספריה בשם locale. בסופו של דבר צריך להתקבל מבנה כזה: C:\bin\locale. שים לב: יש להשתמש באותיות קטנות. ב-Windows זה אמנם לא משנה, אבל אותה חבילת שפה תשמש גם משתמשים במערכות הפעלה אחרות, כמו Linux, שם יש הבחנה בין אותיות גדולות לקטנות. שים את הקובץ he-IL.jar המתוקן בתיקיה locale, ומשם הוסף אותו לקובץ ה-XPI הראשוני שיצרת תוך שמירה על מבנה התיקיות.

בזאת הושלם ביצוע תרגום מימשק התוכנה. עתה, יש לטפל בתרגום קבצי העזרה.

ראו גם

קישורים חיצוניים